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Installation

1 Minimum system requirements

Operating system

RAM

Storage capacity

Serial ports
USB ports
Screen

Network

PDF reader

64-bit version of:

= Windows 11 Pro / Enterprise
= Windows 10 Pro / Enterprise
= Windows Server 2019
= Windows Server 2016

8 GB

Program: 1 GB

Data: 100 GB

for devices with RS-232 interface
for devices with USB interface
Minimum resolution: 1024 x 768
10 Mbit/s, stable and permanent
Communication via TCP/IP

Safety systems, e.qg. firewalls, have an impact on the
performance of the client/server system.

A PDF reader must be installed on the computer.

The Windows user must have administrator rights in order to be able to install

the viva software.

2 Customizing energy options
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During the determination, data loss may occur or there may be communication
problems with certain energy options of the operating system. Proceed as fol-
lows to customize the energy-saving plan settings:

1 Under Control Panel » System and Security » Energy Options,
open the system settings that specify the behavior when the power
switch is pressed or the computer is folded shut.

2 Change the following settings:



= When pressing the power switch: Do nothing

= When pressing the energy saving button: Do nothing
= When closing the lid: Do nothing

» Enable fast start-up: Deactivated

ﬂ NOTICE

To change the Turn on fast start-up option, you may need to enable
it first as an administrator. To do this, click on Some settings are cur-
rently unavailable in the window.

3 Open the energy-saving plan settings under Control Panel » System
and Security » Energy Options. Now click on Change advanced
energy settings.

4 Change the following settings:

= Under Saving energy:
— Deactivation after: Never
— Allow hybrid standby mode: Off
— Hibernate after: Never
= Under USB settings:
— Selective USB energy-saving settings: Disabled

3 Single workplace installation

With the single workplace version viva Full, you can install the client and the
database on your computer.

1 Prior to the installation, disconnect all the USB devices from the computer
on which viva is to be installed.

If the OMNIS Software is already installed on the computer, end the
Metrohm OMNIS DeviceServer service via the Windows Task Manager.

2 Connect the USB flash drive with the viva installation file to the computer
and start the setup.exe file.

If the minimum system requirements are not met (see above), an appro-
priate message appears. Click on [Yes] if you would like to install the pro-
gram nonetheless.

Afterwards, click on [Next >].

3 During the installation process, the Welcome screen appears first. Click on
[Next >] to install the software.
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Metrohm viva Setup X

Welcome to the InstallShield Wizard for viva

The InstallS hield® \Wizard will install viva on your
computer. To continue, click Next,

< Back ' Cancel

4 Read the license agreement for viva and accept it with [Yes].

5 After having accepted the license agreement, a window will appear
where you can enter the license code.

Metrohm viva Setup X ‘

License code

Please type in your license code. n Meh‘ohm

License code [VA30 ”I I“ H[ |“ ||| |

< Back Cancel

Enter the license code for viva Full and then click on [Next >].

E NOTICE

If you have entered the license code of an update license, then the
license code of the previous full version will additionally be requested.



Metrohm viva Setup X ‘

License code

Please type in your license code. n Melh‘ohm

License code (V430 -] - ol - -

@ The licence code is valid only for a program update.
Please enter the licence code of the previous full version.

License code [VATD HI |“ |“ |‘“ |‘|| |

< Back Cancel

Confirm the target folder for the viva installation with [Next >] or select
a different target folder with [Browse...].

Metrohm viva Setup X ‘

Choose Destination Location

Select folder where setup will install files. n Melh‘ohm

Setup will install viva Daily in the following folder.

To install to this folder, click Nest. To install to a different folder, click Browse and select
anather folder.

Destination Folder

C:\Program Files [x86)\Metrohm'wiva D aily Browse...

< Back Cancel

You can define the paths for the database files and default backup files in
the Additional installation information window:
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Metrohm viva Setup X ‘

Additional installation information.

Please enter the necessary information n Meh'ohm

for the operation.

';i) Every user needs read/wiite rights for the specified directaries!

Database path [C:\ProgramData\Metrohm'wviva\D ata

Default backup path |C:\ProgramData\Metrohm'wvivahB ackup

Advanced...

==

E NOTICE

The database path must not be on a network drive.

The default backup path may also be on a network drive.

You can change the ports viva uses to communicate with the database
server and the administration server with the [Advanced...] button. If
the ports are already used, an appropriate error message will appear. Ask
your system administrator for more information about this. Continue with
[Next >].

8 If you would like to create a shortcut on your desktop to start the viva
software, activate [Yes] and then click on [Next >].

Metrohm viva Setup X ‘
Start icon
£). Metrohm
Should a shortcut be created on the desktop?
® Yes
(O Mo

< Back Cancel

9 Confirm the program folder with [Next >] or select a different program
folder.

8.0103.8002EN / 2021-10-18



Metrohm viva Setup X ‘

Select Program Folder

Please select a program folder. n Meh‘ohm

Setup will add program icons to the Program Folder listed below. Y'ou may type a new folder
name, or select one from the existing folders list. Click Mest to continue,

Program Folder:

[Metiohmiviva Dail \

Existing Folders:
7-Zip
Accessibility
Accessonies
Administrative Tools
Cisco

Druva inSync

HF Help and Support
Logitech
Maintenance v

< Back Cancel

10 The installation settings can now be checked. Start the copy process with
[Next >].

Metrohm viva Setup X ‘
Start Copying Files

Review settings before copying files. n Meh‘ohm

Setup has enough information to start copying the program files. |f you want to review or
change any settings, click Back. If you are satisfied with the settings, click Next to begin
copying files.

Current Settings:

Installation viva Daily 3.0:

Target Directory: C:\Program Files [«861\Metrohm\viva Daily
Licensetype: Fulllicense [VA3D-

Database path: C:\ProgramD ata\Metrohm'wiva Daily\Data

Default backup path: C:\ProgramD ata\Metiohmbviva D aily\Backup
Installation mode: Client/Server

Shell Folder. Metrohm\wviva Daily

< Back Cancel

11 The following message appears during the installation of viva:

Metrohm viva Setup X

If you use a firewall program please check its settings.
viva uses the following ports:
6751, 6752, 5845, 5846

This message points out again which ports viva uses. Write down these
ports and inform your system administrator in case viva is not able to
connect to the database. Confirm the message with [OK].

viva will now be installed.
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E NOTICE

During the installation, all device drivers that are required for control-
ling the supported USB devices are installed or updated. If the driver
software needs to be updated, a message appears. Confirm the instal-
lation by clicking on the [Install] button.

12 Once the copying procedure has been completed you can make further
workplace settings:

Metrohm viva Setup X ‘
Workplace settings

Please set your client ID and your n_ Met[ohm
preferred language.

Client ID I

[] This client ID must exist in the current
wviva system.
Language English v
< Back MNext Cancel

The option This client ID must exist in the current viva system. can
only be activated if a database from a previous installation already exists
or if you want to connect to a database server on another computer.

If you enable this option, then viva checks whether the identifier you
have entered exists in the database. If this is the case, the identifier and all
associated settings will be adopted. With this option, reinstalling a client is
much easier.

Click on [Next >]. If the database ports are not available, an appropriate
error message will appear and the installation will be canceled. In this
case, check your server and firewall settings before installing the program
again.

13 At the end of the installation, the file info.txt will be created. This file
contains all relevant information concerning your current viva installation.
Save this file on your hard drive for future reference and print it (add to
installation qualification).
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E NOTICE

An InstallLog file can be found in the installation directory of viva
under ...bin\InstallLog. It contains a listing of all files copied to your
computer during the installation and a confirmation that the installa-
tion has been successfully completed.

14 Complete the installation with [Finish].

If the OMNIS Software is already installed on the computer, start the
Metrohm OMNIS DeviceServer service via the Windows Task Manager
again.

Fonts

On the operating system Windows 10, it may be necessary for the correct dis-
play of East Asian fonts (e.g., in reports) to add the corresponding font. There
are two options to do this. Only carry out one of the two described options.

» Install the missing language.
Procedure for Windows 10, version 1809: Windows Settings » Time &
Language » Language » Add a language

» Download the fonts for all the languages.
Procedure for Windows 10, version 1809: Windows Settings » Person-
alization » Fonts » Download fonts for all languages

4 Client/server installation

With the viva multi version (multi-client version with 3 licenses) you can select
during the installation whether you want to install only a Client or a client
and a server (database server) on your computer.

If you want to install only a client on your computer, a server to which the cli-
ent will be connected must have been previously installed on another com-
puter.

1 Follow steps 1 to 6 of the single workplace installation (see chapter 3,

page 2).

2 The Additional installation information dialog appears. Here you can
select whether you want to install only a client or a client and a server
(database server) on your computer.
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Metrohm viva Setup *

Additional inztallation information.

Please enter the necessary information n Me'mhm

for the operation.

(®) Client/Server

@ Every user needs read/write rights for the specified directories!

Database path ||C: “ProgramD atatketrohmbsivatData |
Cefault backup path ||E: WPragramD atathetrohmwiva\B ackup |
() Client

Advanced..

< Back Caticel

The option Client/Server installs the client and the database server on
your computer. Select this option if your computer will be used as server.

E NOTICE

The default paths are different for the various operating systems.

The database path must not be on a network drive.

The default backup path may also be on a network drive.

With Client, only the client will be installed and you have to select the

database server you would like to use with the -] button. The database
server must already be installed. The network server name or the IP
address is accepted as the name.

You can change the ports viva uses to communicate with the database
and administration server with the [Advanced...] button. If the ports are
already used, an appropriate error message will appear. Ask your system
administrator for more information about this. Continue with [Next >].

3 All further installation steps correspond to those of the single workplace
installation from point 8 onwards (see chapter 3, page 2).

Fonts

On the operating system Windows 10, it may be necessary for the correct dis-
play of East Asian fonts (e.g., in reports) to add the corresponding font. There
are two options to do this. Only carry out one of the two described options.

= Install the missing language.
Procedure for Windows 10, version 1809: Windows Settings » Time &
Language » Language » Add a language

= Download the fonts for all the languages.
Procedure for Windows 10, version 1809: Windows Settings » Person-
alization » Fonts » Download fonts for all languages
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5 Modifying/repairing/removing the installation
and upgrading the license

Modify

Repair/Update

In order to carry out modifications on the current viva installation, start the
setup.exe file from the USB flash drive or click under:

Control Panel » Programs and Features on Metrohm viva. Then select
Uninstall/Change:

XML structure missing: ul

Metrohm viva Setup X ‘
Welcome
Modify, repair, update, or remove the program n Me‘h‘ohm

‘Welcome to the viva Daily Setup Maintenance program. This program lets you modify the
current installation. Click one of the options below.

() Modify
ﬁ Select new program features to add or select cumently installed features to
remove.

(® Repair/Update
ﬁ Reinstall all program features installed by the previous setup.

() License upgrade

fﬂj New license
3%

(O Remove
b‘;] Remave all installed features.
b7

With this option you can adjust the paths to the database and backup files and
change the ports which viva uses for communication. With the viva Multi
version you can additionally change the path to the database server.

If the database path is changed, the existing databases are automatically cop-
ied to the new location.

With this option you can repair an existing defective installation or update an
older installation.

Repairing the installation

In case of a defective viva installation because, for instance, a DLL file is
missing or a program file has been deleted by mistake, viva can be repaired
with this option.

Updating the installation

In case an older version of viva is installed, it will be updated to the new
version of viva.
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License upgrade

Remove

CAUTION

During the updating of older viva versions to viva 3.0 the databases will be
converted to the new version. Depending on the size of the database, this
may take some time. A progress bar showing the status of the conversion is
displayed for each database.

The computer must not be restarted or Windows shut down as long as the
conversion is running!

A direct upgrade of your current installation to a viva version with additional
features is possible with this option:

= viva Full to viva Multi

In order to do this, enter your new license code in the next dialog window.

This option removes your viva installation. Data which has been generated
after the installation (e.g. database entries, log files, exported data, etc.) will
not be deleted.

6 Program update with viva full
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During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically
updated for further use.

H NOTICE

The files in the database directory and the backup directory will be retained
when the program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. The files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.

1 Save the configuration database to an external directory using the backup
function of viva. In the Configuration program part, select the
File » Backup » Manually menu item. Select Backup directory,
enter a name for the backup file and click on [Start]. The backup is car-
ried out. Then copy the backup file to an external storage medium.

2 |If desired, export the methods in addition to the automatic backup with
the configuration database (see above) into an external directory. In the
Method program part, select the File » Method manager... menu

11



item. Select the desired Method group, mark all methods to be
exported and click on [Edit] » Export.... Select the desired export direc-
tory and click on [OK]. The methods are exported to the desired directory.
Then copy the method files to an external storage medium.

3 Save all determination databases created by you to an external directory
using the backup function of viva. In the Database program part, select
the File » Database manager... menu item. Select the desired data-
base and click on [Backup]. Select Backup directory, enter a name for
the backup file and click on [Start]. The backup is carried out. Then copy
the backup file to an external storage medium.

4 Also save further files created by you in the installation directory (e.g.
export files) to an external directory or to an external storage medium.

5 Close viva. Connect the USB flash drive with the installation file to the
computer and start the setup.exe file. Then select Repair/Update and
click on [Next >].

Metrohm viva Setup bt ‘
Welcome
Madify, repair, update, or remave the program n Meh’ohm

Welcome ta the viva Daily Setup Maintenance program. This program lets you modify the
curent installation. Click one of the options below.

() Modify
ﬁ Select new program features to add or select cunently installed features to
remove.

(®) Repair/Update
ﬁ Reinstall all program features installed by the previous setup.

() License upgrade

@ New license
3

(O Remove
rﬁ] Remove all installed features.

Back Cancel

6 Enter your update license code and click on [Next >].
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Metrohm viva Setup X ‘

License code

Please type in your license code n Me‘h‘ohm

License code [VA30 H' ||

< Back Cancel

7 CAUTION

During the updating of older viva versions to viva 3.0 the databases will
be converted to the new version. Depending on the size of the data-
base, this may take some time. A progress bar showing the status of
the conversion is displayed for each database.

The computer must not be restarted or Windows shut down as long as
the conversion is running!

Complete the installation with [Finish].

An UpdateLog file with a list of all files that have been copied to your
computer during the program update and with a confirmation of a suc-
cessful installation is saved in the viva installation folder (default: C:\Pro-
gram Files(x86)\Metrohm\viva) under bin\InstallLog.

7 Program update with viva multi
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During the program update, the configuration database (system configuration,
methods, templates, user-specific data for all clients) and the determination
databases on the server are automatically updated for further use with the new
version of viva multi.
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H NOTICE

The files in the database directory and the backup directory will be retained
when the program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. The files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.

1 Make sure viva multi is closed on all clients.

E NOTICE

In the bin subdirectory of the viva installation, you can find the Cli-
ents.exe application, with which all clients and their status can be dis-
played.

2 Open viva multi on the server and save the configuration database to an
external directory using the backup function of viva. In the Configura-
tion program part, select the File » Backup » Manually menu item.
Select Backup directory, enter a name for the backup file and click on
[Start]. The backup is carried out. Then copy the backup file to an exter-
nal storage medium.

3 If desired, export the methods in addition to the automatic backup with
the configuration database (see above) into an external directory. In the
Method program part, select the File » Method manager... menu
item. Select the desired Method group, mark all methods to be
exported and click on [Edit] » Export.... Select the desired export direc-
tory and click on [OK]. The methods are exported to the desired directory.
Then copy the method files to an external storage medium.

4 Save all of the determination databases on the server to an external direc-
tory using the backup function of viva. In the Database program part,
select the File » Database manager... menu item. Select the desired
database and click on [Backup]. Select Backup directory, enter a name
for the backup file and click on [Start]. The backup is carried out. Then
copy the backup file to an external storage medium.

5 Also save further files created by you in the installation directory (e.g.,
export files) to an external directory or to an external storage medium.

6 Updating the server

Close viva multi on the server and on all clients. Connect the USB flash
drive with the installation file to the server and start the setup.exe file.
Then select Repair/Update and click on [Next >].
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Metrohm viva Setup X ‘

Welcome

Modify. repair, update, or remove the program. n Mehohm

Welcome ta the viva Daily Setup Maintenance program. This program lets you modify the
current installation. Click one of the options below.

) Modify
ﬁ Select new program features to add or select currently installed features to
Temove.

(®) Repair/Update
ﬁ Reinstall all program features installed by the previous setup.

() License uparade
A Newlicense
]

() Remave
@ Remove all installed features.

< Back Cancel

7 Enter the update license code for viva multi and click on [Next >].

Metrohm viva Setup X ‘

License code

Please type in your license code. n MQMhm

License code [v4.30 H| |“ |“ |“ |.|| |

< Back Cancel

8 E NOTICE

The update of viva multi consists of the server license and three client
licenses. If an existing installation contains additional client licenses,
these will be deleted.

Click on [OK] in the corresponding message in order to continue the
installation.
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9 @ CAUTION

During the updating of older viva versions to viva 3.0 the databases will
be converted to the new version. Depending on the size of the data-
base, this may take some time. A progress bar showing the status of
the conversion is displayed for each database.

The computer must not be restarted or Windows shut down as long as
the conversion is running!

Complete the installation with [Finish].

An UpdateLog file with a list of all files that have been copied to the
server during the program update and with a confirmation of a successful
installation is saved in the server's viva installation folder (default: C:\Pro-
gram Files(x86)\Metrohm\viva) under bin\InstallLog.

10 In case additional licenses have been removed during the server update or
if further additional licenses are to be added, the Administrator can
enter them in viva (dialog: Configuration » Tools » Program admin-
istration... » Licenses » Add licenses).

11 Updating clients

Connect the USB flash drive with the installation file to each client in turn
and start the setup.exe file. Then select Repair/Update and click on
[Next >]. Complete the installation with [Finish].

ﬂ NOTICE

To facilitate the updating of many clients at once, the installation can
be copied from the USB flash drive to a writable medium and the file
viva_init.ini can be modified. There, user-defined parameters for the
installation (license code, installation path, server name, etc.) can be set
in advance, so that one needs only click through the installation.

An UpdateLog file with a list of all files that have been copied to the cli-
ent computer and with a confirmation of a successful installation is saved
in the viva client's installation folder (default: C:\Program
Files(x86)\Metrohm\viva) under bin\InstallLog.

If additional licenses were removed at the time of the server update or if fur-
ther additional licenses are to be added, proceed as follows:

Adding additional licenses

1 Open the directory C:\Users\'Username\AppData\Local\VirtualStore
\Program Files (x86)\Metrohm\viva\bin. If there is a file there named
license.mlic, delete it. Repeat this for each user.
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2

3

Right-click on the file setup.exe and select Run as administrator.

Add the desired licenses in the Configuration program part under
Extras » Program administration » Licenses » Add licenses.

The file license.mlic, which contains the standard license code and the
additional license codes, is stored in the bin directory of the program
installation (e.g., C:\Program Files(x86)\Metrohm\viva\bin).

E NOTICE

For more information on adding additional licenses, refer to Chapter 9,
page 18.

8 Installation of drivers
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In normal cases, the installation routine of viva automatically installs all the
driver software necessary for actuating the supported devices.

It may be necessary to install individual driver software manually in combina-
tion with a few devices. This is the case if the operating system displays a mes-
sage when connecting a device to the computer, as e.g. Device driver soft-
ware was not installed. No driver software found. The message should
also show the name of the corresponding device. Write down this name and
proceed as follows to install the driver software manually:

1

Open the Windows Device Manager. The corresponding device can be
found under Other devices.

Right-click on the device. The context menu opens.

In the context menu, select Update driver software. A dialog window
opens.

Select Browse my computer for driver software. The file selection
dialog opens.

Navigate to the installation folder of viva (default: C:\Program Files
(x86)\Metrohm\viva).

Open the drivers subfolder. This contains a subfolder with the required
(*.inf) driver software file for each of the corresponding devices. For
example, the Avantes subfolder contains the driver software for the
Avantes spectrometer.

Apply the selection with [OK]. A Windows safety prompt is displayed. In
order to install the driver, click on [Install].
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8 After successful installation, close the Device Manager.

9 Adding additional licenses

General

Windows 10 has a UAC (User Account Control), which permits running tasks
either as non-administrator or as administrator (without changes of user,
switching off or similar). For more information about this function, see https.//
docs.microsoft.com/en-us/windows/security/identity-protection/user-account-
control/how-user-account-control-works.

This function can cause difficulties with client/server installations of viva.

Problem description

Additional licenses for the program should be added. For this purpose, the
license code for an additional 5 licenses, for example, has been added (on the
server) in the Configuration program part in the Program administration
dialog window (accessible via the Tools » Program administration... menu
item, Licenses tab).

Normally the license.mlic file, which contains the standard license code and
the additional license codes, is stored in the bin directory of the program
installation (e.g. C:\Program Files(x86)\Metrohm\viva\bin).

However, it may happen that the 5 licenses have been added and the
license.mlic file contains only the standard license code (for 3 licenses). If this
is the case, check whether there is a file named license.mlic in the C:\Users
\'Username\AppData\Local\VirtualStore\Program Files (x86)\Metrohm
\viva\bin directory. This file contains the license codes for the standard licenses
and the 5 newly added licenses, i.e. the additional licenses were stored in the
VirtualStore only for the Windows user who was logged in on the PC at the
time the additional licenses were added.

On the server, the program recognizes all of the licenses. The operating system
adds the license.mlic file from the C:\Users\'Username"\AppData\Local
\VirtualStore\Program Files (x86)\viva\bin directory to the detail list of the
C:\Program Files (x86)\Metrohm\viva\bin directory.

The license.mlic file in the C:\Program Files (86)\Metrohm\viva\bin direc-
tory determines the client/server functionality of the database server, however,
and here only the basic license is listed. Therefore, problems are to be anticipa-
ted when adding additional clients (more than the 3 clients present in the
default settings). To fix this, the license.mlic file must be deleted from the Vir-
tualStore.

Remedy

= For new installations
— Start the program as an administrator.
— Add the license code for additional licenses as usual. The
license.mlic file in the C:\Program files(x86)\Metrohm\viva\bin
directory contains both license codes.
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» For existing installations

— In the C:\Users\'Username"\AppData\Local\VirtualStore\Pro-
gram Files(x86)\Metrohm\viva\bin directory, check whether there
is a file present named license.mlic and delete it if necessary.

— Start the program as an administrator.
Add the license code for additional licenses as usual. The
license.mlic file in the C:\Program files(x86)\Metrohm\viva\bin
directory contains both license codes.

10 User rights for viva

In order for the logged-in user to be able to access all functions with viva, the
Windows system administrator must ensure that the permissions are set for the

directories as listed below:

Directory Permission Group name or
user name

Database directory Modify SYSTEM

Directory where the databases will be saved (...\Data). User’

Backup directory Modify User

Directory where the backups will be stored (...\Backup).

%PROGRAMDATA%\Metrohm™ Modify User’

Export directories Modify User

Directories where the exported files are to be saved.

PDF directories Modify User

Directories where the PDF files are to be saved.

Desktop Modify User”

Installation directory, e.g. %PROGRAMFILES(x86)% Read & execute | User’

\Metrohm\viva

*

User = name of the user who is logged in

*%

Administrators, Users, Guests, Main users.

During installation of viva the permission Full Control is set for the following groups: SYSTEM,

H NOTICE

The BackupServer.exe process must be started for carrying out a backup
(backup of the configuration database and of the determination databases).
You can check this under "Windows Task Manager".

The user must be logged in during the whole backup process.
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